Print This Page

LS9 Editor V2.1.4 for Mac OS X 10.5-10.8 (Previous version)

Important Notice

  • This version is comapatible with OS X Mountain Lion (10.8), but does not support Gatekeeper, follow the instruction below when installing or uninstalling the software.
    1. Hold down the "Control" key on your keyboard and click the installer package. Then a pop-up window will be displayed.
    2. Choose "Open" from the pop-up window.
  • The LS9 Editor is for use with Studio Manager V2 Host and Network Driver. Be sure to use the latest versions of both the Studio Manager V2 Host and Network Driver. Both are available from this site.
  • Use the Editor software only with a supported firmware version.
  • Files saved using later Editor or console versions cannot be loaded into earlier versions.

LS9 Compatibility (Mac)

LS9 Editor Studio Manager
V2 Host
LS9 Firmware
2.1.4 2.3.4 1.33, 1.30
2.1.3 1.21, 1.20, 1.18, 1.17
  • On the Macintosh, do not execute the Studio Manager Host via Rosetta. The LS9 Editor cannot be added to the Studio Manager via Rosseta.


  • Now compatible with LS9 firmware V1.30.


  • Now provides the uninstaller. With this uninstaller, LS9 Editor of a previous version is also uninstallable. Follow the instructions below to uninstall the LS9 Editor.
    1. After the downloaded compressed file is properly extracted, double-click the file "Uninstall LS9 Editor".
    2. Follow the on-screen instructions to uninstall the software.

System Requirements

OS Mac OS 10.5.8/ 10.6.x/ 10.7.x/ 10.8.x
CPU Intel Core family proccesor
Memory 1GB or more
HDD 100 MB or more
Display 1024 x 768 pixels or higher; High Color 16-bit or higher
Other Ethernet (100Base-TX/10Base-T) port

License agreement and software

LS9 Editor V2.1.4 for Mac OS X 10.5-10.8 (Previous version)

You also need to download these files.

You are recommended to download these files.

Return to Top