Print This Page

LS9 Editor V2.1.4 for Win 10/8.1/8/7/Vista/XP

Important Notice

  • The LS9 Editor is for use with Studio Manager V2 Host and Network Driver. Be sure to use the latest versions of both the Studio Manager V2 Host and Network Driver. Both are available from this site.
  • Use the Editor software only with a supported firmware version.
  • Files saved using later Editor or console versions cannot be loaded into earlier versions.

LS9 Compatibility (Win)

LS9 Editor Studio Manager
V2 Host
LS9 Firmware
2.1.4 2.3.1 1.33, 1.30
2.1.3 1.21, 1.20, 1.18, 1.17
2.1.2 2.3.1, 2.3.0, 2.1.7 1.16, 1.15, 1.14
2.1.1 1.13, 1.12, 1.11, 1.10
2.1.0 1.01, 1.00
  • Files saved using later Editor or console versions cannot be loaded into earlier versions.
  • Please note that some types of USB flash memories cannot be used for firmware updates, or cannot be accessed from the LS9 at all.

How to update the firmware

  • Before performing any firmware upgrade it is good practice to back-up console data to a USB memory device.
    1. Copy the following file to root directory of your USB memory.
    LS9Px_xx.PGM (x_xx shows the version number.)
    2. Insert your USB memory and power on.
    3. LS9 detects the file and shows the following message.
    "Start Loading? CANCEL[DEC]/OK[INC]"
    4. Then press [INC] key to start updating the firmware.
    5. Wait until completing the update. LS9 automatically restarts and becomes ready to use.
    6. Initialize LS9.

Performance Limits and Specifications

  • They are the same as V1.10.

Main Revisions and Enhancements

Change

  • Now compatible with LS9 firmware V1.30.

System Requirements

OS Windows 10/8.1/8 Windows 7 (SP0/SP1) Windows Vista (SP0/1/2) Windows XP (SP2/3)
CPU 32-bit : 1.4GHz or higher
64-bit : Intel 64 compatible processor
32-bit : 1.4GHz or higher
64-bit : Intel 64 compatible processor
32-bit : 1.4GHz or higher 800MHz or higher
Memory 32-bit : 1GB or more
64-bit : 2GB or more
1GB or more 512MB or more
HDD 100 MB or more
Display 1024 x 768 pixels or higher; High Color 16-bit or higher
Other Ethernet (100Base-TX/10Base-T) port

former version information.

Editor V2.1.3 for Win

Change
  • LS9 Editor V2.1.3 is now compatible with LS9 firmware V1.17.
Improvement
  • Changed the initial value of COMM PORT in the EXTERNAL HA from "----" to "SLOT1" ("SLOT" for the LS9-16). Also changed the initial values of the EXTERNAL HA PORT SELECT parameter from "#1" to "SLOT1 1-8," "#2" to "SLOT1 9-16," "#3" to "SLOT2 1-8," and "#4" to "SLOT2 9-16." (There is no #3 and #4 on the LS9-16.)

Editor V2.1.2 for Win

New Feature
  • Now supports Windows 7
New Features
  • LS9 Editor V2.1.2 is now compatible with LS9 firmware V1.14.
  • Made it possible to return to normal operation by operations such as clicking on the desktop, when your computer froze up during the use of the menu bar. In V2.1.1 or former versions, LS9 Editor infrequently froze up depending on your computer or OS, if the cursor had been moved to the title bar the moment the menu was shown, or if the mouse had been moved left or right repeatedly with the menu shown on the display.
  • Lessened a problem in which a message "No more editor windows can be opened at this time." was shown and no further windows could be opened by improving the internal processing.
  • Fixed a problem which could occur in some edit boxes when trying to enter values directly from your keyboard.
  • Fixed a problem in which an umlaut character that was normally unable to be used could be entered in the TITLE field etc. of the Library window and the Scene window. If you synchronize libraries and scenes where titles and comments have umlaut characters with the LS9 unit, the unit will freeze up or a message "Sync. Error" will be displayed. TOP

Editor V2.1.1 for Win

New Feature
  • LS9 Editor V2.1.1 is now compatible with LS9 firmware V1.10.

Editor V2.1.0 for Win

New Feature
  • The first release version.

License agreement and software

LS9 Editor V2.1.4 for Win 10/8.1/8/7/Vista/XP

You also need to download these files.

You are recommended to download these files.

Return to Top