Print This Page

TF Editor V1.10 for Win 8.1/8/7 (Previous version)

Important Notice

TF Firmware V1.10 or later is required to use the TF Editor and TF StageMix. Please make sure to use appropriate version of TF Editor which is compatible with your console firmware in reference to the following compatibility chart.

TF Editor(Win)/Firmware Compatibility

TF Editor TF Firmware
1.10 1.10
- 1.01

[Notice: Checking the version number]
You may check the TF main firmware version number from the version field in the About screen of the SYSTEM SETUP screen.

Main Revisions and Enhancements

Editor V1.10

  • The initial release version.

System Requirements

OS Windows 8.1/8 Windows 7
CPU Intel Core Processor (including 64-bit Processors) running at 2GHz or faster
Memory 1GB or more (2GB or more if useing a 64-bit processor)
HDD 100 MB or more
Display 1280 x 768 or higher resolution, 16-bit or higher color depth
Other Pointing devaice(mouse, trackpad, etc), Ethernet connection (100BASE-TX/10BASE-T)

License agreement and software

TF Editor V1.10 for Win 8.1/8/7 (Previous version)

Return to Top